スポンサーリンク
スポンサーリンク

【Cisco VRF間通信】 Static routeによるVRF Route-Leaking

【概要】

Static routeによるVRF-lite間のRoute-leakの方法を記載する。
通常、VRFをまたいだ通信は通常できないが、要件によりVRFをまたいだ通信が必要な時がある。
その場合、以下の方法でVRF間の通信を可能にする。

構成

route-leak1-2

以下の設定をすることで、PC1 → PC2へ通信することが可能(通常不可)

Config

R1-config click
hostname R1
!
interface GigabitEthernet0/0
 ip address 10.12.1.1 255.255.255.0
!
interface GigabitEthernet0/1
 ip address 192.168.1.254 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 10.12.1.2
!
control-plane
!
end
R2-config click
hostname R2
!
ip vrf AAA
 rd 1:1
!
ip vrf BBB
 rd 2:2
!
interface GigabitEthernet0/0
 ip vrf forwarding AAA
 ip address 10.12.1.2 255.255.255.0
!
interface GigabitEthernet0/1
 ip vrf forwarding BBB
 ip address 10.23.1.2 255.255.255.0
!
ip route 10.12.1.1 255.255.255.255 GigabitEthernet0/0
ip route 10.23.1.3 255.255.255.255 GigabitEthernet0/1
ip route vrf AAA 10.1.1.100 255.255.255.255 10.23.1.3 global
ip route vrf BBB 192.168.1.100 255.255.255.255 10.12.1.1 global
!
control-plane
!
end
R3-config click
hostname R3
!
interface GigabitEthernet0/0
 ip address 10.1.1.254 255.255.255.0
!
interface GigabitEthernet0/1
 ip address 10.23.1.3 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 10.23.1.2
!
control-plane
!
end

コマンドのポイント

route-leak1-1

 

 

 

 

VRFテーブルに別のVRFルートを載せる

【VRF AAA】に【VRF BBB】のセグメントを載せるため、以下のコマンドを設定する。
※ 10.1.1.100/32は【VRF BBB】に所属している。

ip route vrf AAA 10.1.1.100 255.255.255.255 10.23.1.3 global

【VRF BBB】に【VRF AAA】のセグメントを載せるため、以下のコマンドを設定する。
※ 192.168.1.100/32は【VRF AAA】に所属している。

ip route vrf BBB 192.168.1.100 255.255.255.255 10.12.1.1 global

VRFテーブルに別のVRFルートを載せる

Next-HOPがどのIFに属しているかを明示する。

ip route 10.12.1.1 255.255.255.255 GigabitEthernet0/0
ip route 10.23.1.3 255.255.255.255 GigabitEthernet0/1

ルーティングテーブル確認

VFR AAA ルーティングテーブル (R2)

R2#show ip route vrf AAA

Routing Table: AAA
Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
S        10.1.1.100/32 [1/0] via 10.23.1.3
C        10.12.1.0/24 is directly connected, GigabitEthernet0/0
L        10.12.1.2/32 is directly connected, GigabitEthernet0/0

VFR BBB ルーティングテーブル (R2)

R2#show ip route vrf BBB

Routing Table: BBB
Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        10.23.1.0/24 is directly connected, GigabitEthernet0/1
L        10.23.1.2/32 is directly connected, GigabitEthernet0/1
      192.168.1.0/32 is subnetted, 1 subnets
S        192.168.1.100 [1/0] via 10.12.1.1

おまけ)グローバルルーティングテーブル(R2)

R2#show ip route

Gateway of last resort is not set

      10.0.0.0/32 is subnetted, 2 subnets
S        10.12.1.1 is directly connected, GigabitEthernet0/0
S        10.23.1.3 is directly connected, GigabitEthernet0/1

 

VRF-lite
スポンサーリンク
スポンサーリンク