スポンサーリンク
スポンサーリンク

[bgp redistribute-internal] ルート再配布に必要な場合あり

【概要】
iBGP経路をIGP(OSPF/EIGRP/RIPなど)に再配布する場合に[bgp redistribute-internal]コマンドは必須になる。以下でOSPFへiBGP経路を再配布の可否を確認する。

構成

  • R1 ⇔ R2 間はOSPFでルーティングする。
  • R2 ⇔ R3 間はiBGPでルーティングする。
  • R3にLoopaback(3.3.3.3/32)アドレスを設定し、それをnetworkコマンドでR2にBGPで広報する。
  • R1にLoopaback(1.1.1.1/32)アドレスを設定し、それをnetworkコマンドでR2にOSPFで広報する。
  • R2でBGPからOSPFへ再配布する。
  • R2でOSPFからBGPへ再配布する。
R2にて(3.3.3.3/32)をBGPからOSPFに再配布し、R1で(3.3.3.3/32)がOSPFで経路を載せたい

config

R1-config
hostname R1
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface GigabitEthernet0/0
 ip address 10.12.1.1 255.255.255.0
 duplex auto
 speed auto
 media-type rj45
!
router ospf 1
 network 1.1.1.1 0.0.0.0 area 0
 network 10.12.1.0 0.0.0.255 area 0
!
control-plane
!
end
R2-config
hostname R2
!
interface GigabitEthernet0/0
 ip address 10.12.1.2 255.255.255.0
!
interface GigabitEthernet0/1
 ip address 10.23.1.2 255.255.255.0
!
router ospf 1
 redistribute bgp 100 subnets
 network 10.12.1.0 0.0.0.255 area 0
!
router bgp 100
 bgp log-neighbor-changes
 bgp redistribute-internal
 neighbor 10.23.1.3 remote-as 100
!
control-plane
!
end
R3-config
hostname R3
!
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface GigabitEthernet0/1
 ip address 10.23.1.3 255.255.255.0
!
router bgp 100
 bgp log-neighbor-changes
 network 3.3.3.3 mask 255.255.255.255
 neighbor 10.23.1.2 remote-as 100
!
control-plane
!
end

[bgp redistribute-internal] 設定がある場合

R1#show ip route ospf
Gateway of last resort is not set
      3.0.0.0/32 is subnetted, 1 subnets
O E2     3.3.3.3 [110/1] via 10.12.1.2, 01:28:19, GigabitEthernet0/0
意図通り、R3から[3.3.3.3/32]がOSPFに再配布されている
R3#show ip route bgp
Gateway of last resort is not set
      1.0.0.0/32 is subnetted, 1 subnets
B        1.1.1.1 [200/2] via 10.12.1.1, 00:17:58
      10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
B        10.12.1.0/24 [200/0] via 10.23.1.2, 00:18:03
意図通り、R1から[1.1.1.1/32]がBGPに再配布されている

[bgp redistribute-internal] 設定がない場合

R1#show ip route ospf
Gateway of last resort is not set

[bgp redistribute-internal]を設定しないと、想定通りiBGPルートはIGPへの再配布はされなくなる。
※OSPFによるルートは無くなる
R3#show ip route bgp
Gateway of last resort is not set
      1.0.0.0/32 is subnetted, 1 subnets
B        1.1.1.1 [200/2] via 10.12.1.1, 00:17:58
      10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
B        10.12.1.0/24 [200/0] via 10.23.1.2, 00:18:03
[bgp redistribute-internal]を設定しなくても、OSPF(IGP)からiBGPへの再配布には影響しない。
※OSPF(IGP)からiBGPへは再配布する
スポンサーリンク